这篇文章上次修改于 502 天前,可能其部分内容已经发生变化,如有疑问可询问作者。

1528693873.jpg

准备

下载安装 Oracle VM VirtualBox

get openwrt虚拟机镜像

可以到download下载编译打包好的VDI或vmdk镜像
当然也能自己编译
Snipaste_2018-09-04_17-02-41.png

虚拟机配置

创建openwrt虚拟机

Snipaste_2018-09-04_19-32-12.png
实体机需要双网卡,实现wan和lan,我这里使用wlan连接外网
eth0 -> wan (连接外网)
eth1 -> lan (dhcp服务端)

设定一个nat网络,用来连接wan
Snipaste_2018-09-04_19-33-07.png
另一个桥接到物理网卡,连接lan
Snipaste_2018-09-04_19-33-14.png

修改网络配置
Snipaste_2018-09-04_20-07-20.png

config interface 'lan'
    option type 'bridge'
    option ifname 'eth1'
    option proto 'static'
    option ipaddr '192.168.10.1'
    option netmask '255.255.255.0'

config interface 'wan'
    option ifname 'eth0'
    option proto 'dhcp'

Snipaste_2018-09-04_20-13-47.png
其实改下这两处就行

完成后openwrt会自动分配给物理网卡IP地址,这时候wifi和物理网卡都可以上网,host如果要访问internet就会非常缓慢。
一个简单的解决方法是手动设置IP,不指定网关。
Snipaste_2018-09-04_20-33-05.png

连接至路由

重启虚拟机
浏览器访问192.168.10.1
Snipaste_2018-09-04_20-36-14.png

树莓派网口连接试试
Snipaste_2018-09-04_20-42-10.png
Found it!
Snipaste_2018-09-04_20-43-50.png
connection